[SOLVED] Image sequence in material is not played

To make a cutscene in game I’ve used material witn image texture and image sequence. It’s ok, when I play animation with timeline in viewport. However I can’t find how to start timeline in the trait to change frames, so in game I see only the first frame. I use only logic nodes. Could anybody help me?

I stand to be corrected as it’s been long I tried this so hopefully other community members can assist. Last time I checked Armory didn’t support this. The way to go around this is to create a video, probably it’s mp4. Put it in your image texture. Then you download the ffmpeg Library, link it with your Armory. And it plays, will check the examples if there are any changes and update you.

Hello and welcome to the forum.

I don’t believe the Image Sequence type for the Image material node is supported in Armory. What Armory supports instead are Tilesheets. Unfortunately though, if I remember correctly, you’ll need to use a bit of Haxe code in order to activate / run the tilesheets.



As @ ArmoredDP already mentioned, if you’re using video instead, you’ll need to download the FFmpeg library. Additionally, the feature is not supported in Krom (JS), which is the default export type with the Armory Player. The feature is supported in native (HL) builds and HTML5 builds though.

Thanks to everybody! Maybe I’ll try video. I use tilesheets, they work fine for 2d VFX, however to put a lot of frames into one piece is not a pleasant work :slight_smile: .

There are numerous tools that you can use online or offline that can do the embedding of the sprites for you, if you’re interested. GIMP supports a tilesheet plugin, for example, although that may not be what you’re looking for.