[SOLVED] Krom doesn't run game due to shader compilation error?

When I press F5 it shows up as compiling then stops. No errors show in the viewport and this shows up in the console:

Compiling shader 7 of 32 (deferred_light.frag.glsl) failed:
Shader compiler error.
(node:19036) UnhandledPromiseRejectionWarning: Shader compiler error.
(node:19036) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 2)
(node:19036) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
Finished in 5.728663444519043
ERROR: Build failed, check console

Any ideas?

Also yes this is my third question post in less than a week. Sorry.

Please look here. Perhaps your problem has already been described here: https://github.com/armory3d/armory/issues/1289

2 Likes

Did it work before? If it did, do you remember what changed that could’ve lead to the issue?

Can you share a screenshots of your settings in the Armory Render Path panel that it’s in the Render Properties tab?

Please look here. Perhaps your problem has already been described here: github. com/armory3d/armory/issues/1289

I don’t think it’s this problem in particular since that issue shouldn’t trip the compiler. Extra lights should be just simply ignored in the rendering process.

3 Likes

Yes, it did work before. There used to be another error that popped up about a rig but I solved it (by deleting the rig and all the animations lol) but couldn’t figure out how to solve this one. Here are my settings:



image



image

ps. it runs in browser but some lights don’t show up (they’re spotlights so maybe the issue you mentioned is the problem?)

Hold up never mind I deleted the spotlights in my scene and it ran perfectly so I guess that was the problem. Thanks anyway :slight_smile:

yeah that was the problem. thanks

Oh ok, my bad, I thought it didn’t cause any errors but was wrong. Hopefully when the atlasing feature is done you can have a lot of lights in your scene :smiley:

1 Like

Could be this issue: https://github.com/armory3d/armory/issues/1772

3 Likes