[Solved] Lighting issue (Causes: Cache issue)

The scene has lights, any idea they does not show in game ?

That doesn’t help at all, maybe try sharing the .blend file or try giving more information such as render path or thing like ‘updated armory nightly build’.

You can download it here

It’s working fine for me. Just clean the project and re run.

I tried, but it’s too dark, i don’t understand what is going on.

why are you using deferred shading? deferred shading is only has one light support now, this is being fixed by lubos, in meantime use Forward Shading.

Forward does not change the lighting , there is not enough lighting compared to the rendered view (using nighty build).

Actually its the other way around:

The deferred renderer is the default in Armory and the one used in all of the examples.

Ahh my bad. So, it actually opposite

Part of it it might be the Voxel AO that you have enabled. If I disable it the very black shadows on the buildings disappear ( of course voxel anything doesn’t work on my GPU ). It still looks pretty dark, though.

Edit: I just deleted the sun and added a new one and the light popped up. I don’t know what was wrong with it, but that fixed it. For some reason the old ones weren’t casting light. After replacing the lights, it works even with Voxel AO on.

1 Like

This is the best to delete and restart sometimes.
Perhaps it was some cache issue or something like that.

1 Like