[SOLVED] Mouse node, not like Keyboard node?

I have the following node tree. It should rotate an object under the cursor when the button is pressed.

As shown, it is not working when the left mouse button is down. However, if I connect the keyboard node instead, it does work when I hold the ‘a’ key. What do I need to do to get the mouse button working?


I’m a total noob, any help is appreciated. Should the mouse and keyboard nodes work basically the same? I’m trying to (somewhat) follow the tutorial here: Make a game with draw nodes using Armory 3D (Full tutorial) #armory3d - YouTube


I just tried the setup above and I could not reproduce this issue. It works for both keyboard and mouse for me. Maybe try cleaning (the button next to play button) the project before running it. If it still does not work, please check the Blender System Console.

1 Like

Thanks, that gave me some motivation to check it out some more, since you couldn’t reproduce it must be on my end.

Turns out I had another Mouse node in another trait. I deleted that and it started working as expected.

1 Like