[SOLVED] Once saw thread/post about ~compilation errors on Linux with Codeblocks~ can't find it now

I cant find one thread or issue that I once saw regarding compilation errors on Linux using Codeblocks.
I made a thread about this problem here.
It was either posted on this forum or the Github Armory repo.

The solution in this post was to change the compiler flags in Codeblocks.
I think that there was maybe a picture like this included:

Some Mod/Dev or multiple have responded to this (so they might know it).
If someone knows were this is, please post a link to it here.

1 Like

Is this the one?

That is my own post that I already linked myself.

The one that I’m searching was posted by someone else.

Or on Discord perhaps? There is this:

Just added -ldl -lm -lstdc++ -lpthread -g to the global compiler settings directly in codeblocks

The only other thing I can find is this issue on Github.


Oops. Sorry. I didn’t look at the username. :smile:

Does not help on Manjaro. Exactly the same error as before.

In file included from …/…/…/…/…/ArmorySDK2212/Kha/Backends/Kinc-HL/kinc-bridge/bridge.c:1:
…/…/…/…/…/ArmorySDK2212/Kha/Backends/Kinc-HL/kinc-bridge/arrays.c.h: In function ‘hl_kinc_bytearray_setint16_le’:
…/…/…/…/…/ArmorySDK2212/Kha/Backends/Kinc-HL/kinc-bridge/arrays.c.h:115:34: error: lvalue required as unary ‘&’ operand
115 | int8_t *data = (int8_t *)&((int16_t)value);
| ^
…/…/…/…/…/ArmorySDK2212/Kha/Backends/Kinc-HL/kinc-bridge/arrays.c.h: In function ‘hl_kinc_bytearray_setuint16_le’:
…/…/…/…/…/ArmorySDK2212/Kha/Backends/Kinc-HL/kinc-bridge/arrays.c.h:121:34: error: lvalue required as unary ‘&’ operand
121 | int8_t *data = (int8_t *)&((uint16_t)value);
| ^
…/…/…/…/…/ArmorySDK2212/Kha/Backends/Kinc-HL/kinc-bridge/arrays.c.h: In function ‘hl_kinc_bytearray_setint32_le’:
…/…/…/…/…/ArmorySDK2212/Kha/Backends/Kinc-HL/kinc-bridge/arrays.c.h:127:34: error: lvalue required as unary ‘&’ operand
127 | int8_t *data = (int8_t *)&((int32_t)value);
| ^
…/…/…/…/…/ArmorySDK2212/Kha/Backends/Kinc-HL/kinc-bridge/arrays.c.h: In function ‘hl_kinc_bytearray_setuint32_le’:
…/…/…/…/…/ArmorySDK2212/Kha/Backends/Kinc-HL/kinc-bridge/arrays.c.h:133:34: error: lvalue required as unary ‘&’ operand
133 | int8_t *data = (int8_t *)&((uint32_t)value);
| ^
make: *** [makefile:428: bridge.o] Error 1

That’s the post that I was trying to find.

Can someone please tell, what the link says. I finally managed to register with discord, after many futile attempts. Now login does not work. Again. I am fed up with this discord. It is easier to get into Fort Knox.
If nobody tells me i rather renounce.

1 Like

Thanks, but same error persists. I wonder what Distro 1k8 was using.

These errors are likely fixed after https://github.com/Kode/Kha/pull/1438 makes it into the Armory SDK. If you don’t want to wait, simply apply these changes to <sdk-path>/Kha/Backends/Kinc-HL/kinc-bridge/arrays.c.h and build the project again.

1 Like

Hi, Easy as pie. Compiles flawlessly now. When i try to run it, i get:

Release]$ ./defcube_1_0_1
Starting KincHL
Using OpenGL version 4.6 (forward-compatible).
Uncaught exception: Null access

But at least it compiles. OK, found it. You need to copy the executable from the Release folder to Linux-hl. Then it will start! (Kudos to Github User Notwarp as stated in the thread Timodriaan pointed out above. Does not work with Vulkan or Auto settings. OpenGL only.

Edited file. If someone wants to try, change hx to h in the filename and simply replace the file with the same name in the SDK. You might want to check my editing of it. Just to make sure.
arrays.c.hx (8.6 KB)