[SOLVED] Problems with volumetric lights using lamps was not sun

I had the Armory open and doing some tests, among these tests was to do lighting tests. I used the volumetric light using a sun lamp, while the camera was in a box with holes, so far so good, working and beautiful. However when adding another non-sun style lamp (such as spot), the armory did not build and play, the problem only happened if the volumetric light option was enabled, if I changed the ownership of the spot lamp to sun , it worked. I tested with all the different lamp options and the result was the same. Do I have to activate something I don’t know or is it a bug?

One of the things I wanted to see happen is a flashlight light effect with the volumetric light on a spot lamp.

Is it possible to provide a test file? It may be useful to solve the problem.

Of course! forgot to put in the post.
I created another file and get it to play with another lamp, but when I put more than one lamp in the scene the game didn’t play.

Problem file:
Lamp.blend (953.0 KB)

New file:
untitled.blend (684.0 KB)

At present, it seems that volumetric light cannot be set when there are multiple lights.
I couldn’t fix it so I reported a bug on github.(https://github.com/armory3d/armory/issues/1480)


Aaah ok
Thanks man!

Hi, I want to know if armory can make multiplayer games

You can create another topic for this question

Normally I would simply migrate/merge the offtopic question to a new thread, but since the offtopic question was asked over 4 years ago, I’m not going to bother unless the thread OP explicitly requests it or the offtopic OP responds to your statement, to avoid unnecessary spam.

1 Like

oops, I didn’t know that this question was written about 4 years ago, the forum wrote me only the date of publication of the question on the mobile version of the forum, sorry

1 Like