Task 'assembleDebug' not found in root project 'myapk_1_0_1' - error when compiling to apk

Task ‘assembleDebug’ not found in root project ‘myapk_1_0_1’ - error when compiling to apk


Hi, what version of Armory 3d are you using currently? Also, could you please share the complete debug info from the Blender’s debug console.

I’m using: ArmorySDK2108

Using these instructions: https://www.youtube.com/watch?v=OSKzDGNntkA

Here’s the whole message from the console:

Read prefs: C:\Users\Brian\AppData\Roaming\Blender Foundation\Blender\2.93\config\userpref.blend
Armory: Proxy objects synchronized
Starting App Manager server (port 8668, package BLENDER)
Address already in use, exiting
Info: Total files 1 | Changed 1 | Failed 0
Info: Saved “untitled.blend”

Info: Saved “untitled.blend”

Info: Saved “untitled.blend”

Project cleaned
Armory v2021.8 ($Id: 7adebe05bb6fea0a0cd02fed7b31987a19c73bab $)
Saved: ‘C:\Users\Brian\Desktop\apk\build_untitled\compiled\Assets\envmaps\env_World.jpg’
Time: 00:00.54 (Saving: 00:00.29)

CMFT info: Converting latlong image to cubemap.
CMFT info: Saving spherical harmonics coefficients to C:\Users\Brian\Desktop\apk\build_untitled/compiled/Assets/envmaps/env_World_irradiance.c
CMFT info: Done.
Exporting Scene
Scene exported in 0.005s
Info: Publishing project, check console for details.

Finished in 7.586s
Exported Android Studio project to C:\Users\Brian\Desktop\apk\build_untitled\android-hl-build\myapk_1_0_1

Building APK
Starting a Gradle Daemon (subsequent builds will be faster)

FAILURE: Build failed with an exception.

  • What went wrong:
    Task ‘assembleDebug’ not found in root project ‘myapk_1_0_1’.

  • Try:
    Run gradlew tasks to get a list of available tasks. Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

ERROR: Building the APK failed, check console

Okay, do you have Android Studio installed? The reason I ask is there was an error in exporting to Android before, and I recently fixed it. However, it has not yet been updated into the current version of SDK.

If you do have the Android SDK, then the fix in your case might be as simple as replacing 2 files in the SDK.

I do not have it installed, I’m using the zip - like in the YouTube video

1 Like

In order to publish your app as a final product you will still need to use android studios… The zip file is only for testing the app on a device quickly.

OK, I’ll try this. Thanks!


Didn’t work, and only tried to create an app with a cube in it. Android is getting like trying to develope for iOS :frowning: