Terrible noise while debugging

Friends, I should warn you about the terrible loud noise which starts when I run the debugging session from KodeStudio. I develop my project using Armory_05_mac_b28. This noise can make you deaf if you wear the headphones.

1 Like

Hey, we had one more guy reporting fancy noises on macOS so far - please tell us more about your Mac.

Model Name: Mac mini
Model Identifier: Macmini6,1
Processor Name: Intel Core i5
Processor Speed: 2,5 GHz
Processor Count: 1
Total Cores Amount: 2
L2 Cache: 256 КБ
L3 Cache: 3 МБ
Boot ROM Version: MM61.010D.B00
SMC Version: 2.7f1
Intel HD Graphics 4000:
Chipset: Intel HD Graphics 4000
Type: GPU
Bus: Embedded
VRAM: 1536 МБ
Manufacturer: Intel
ID: 0x0166
Revision: 0x0009
Metal: Supported, macOS GPUFamily1 version 3
Resolution: 2560 x 1440 (QHD/WQHD — Wide Quad High Definition)
Interface Type: 2560 x 1440 @ 59 Hz
Color Buffer Depth: Color 24 bits (ARGB8888)
Default Monitor: Yes
Synchronisation: Off
Online: Yes
Connection Type: DisplayPort
Embedded Input:
Default inputdevice: Yes
Output Channels: 2
Manufacturer: Apple Inc.
Current Frequency: 44100
Transport: Embedded
Input audio signal: Linear input
Embedded output:
Default Output Device: Yes
Default System Output Device: Yes
Manufacturer: Apple Inc.
Output Channels: 2
Current Frequency: 44100
Transport: Embedded
Output Signal Origin: Headphones
Manufacturer: Apple Inc.
Output Channels: 2
Current Frequency: 44100
Transport: DisplayPort
Output Signal Origin: BenQ LCD
System Applications:
System Version: macOS 10.13.4 (17E199)
Kernel Version: Darwin 17.5.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Protected Virtual Memory: On
System Integrity Protection: On

Thanks! Do you know how to compile and run regular Kha applications in Xcode? I’d like to figure out whether that sound is exclusive to Krom.

Wait a moment, now I remember more clearly. I already disabled audio by default a while ago because of that other guy’s noise report (see https://github.com/Kode/Krom/commit/012d4722737fe3e0db507c7045a5ec23955ad9c3) and didn’t plan to re-enable it before Krom get’s multithreaded audio support. Sorry, I’m getting old. No more noise with the next Amory release then I suppose.

I’ve the same problem when export to android.

That should also be resolved in next (final 0.6!) build. :slight_smile:

1 Like