The ground mesh is crazy! What's wrong ?! (+ Screenshot WIP)


The ground mesh is crazy! What wrong ?!

background.blend (3.5 MB)
tree-asset.blend (747.3 KB)

I’m creating a game. It will become a “beat them all” or not it’s the begin of the project!

main character

the first stage

Triangulate the mesh

Try cleaning the project with the “Clean” button under the Armory Player to clean cache. AFAIK Armory doesn’t seem to be detecting correctly changes in materials and meshes to trigger a shader recompile, so shader cache or another cache seems to be the issue. Happened to me when plugging in a normal node to materials.

Also I didn’t find an option to change clipping in the “viewport camera”, so I recommend using a normal camera for far views until the viewport camera clipping is exposed in the editor.

the “Clean project” button is the silver bullet of many issues! I will remember me it for next.

Yeah, hopefully the necessity for that button could be mitigated in the future, but that would require some “help” from Blender to find when to reconstruct cache. Not sure if that info is given by Blender at the moment. If not maybe it can be asked to Blender developers for the addition.