Trouble with node trees that dont exist

I’m new to this type of thing. And like most new people I’m having troubles.

I have a node tree that is actively working to make a player model move. But for some reason whenever I run armory (F5) I get a warning saying that node tree doesn’t match node trait. and it creates 2 new files with different names.

Any idea?

It probably means that your node tree name does not begin with an uppercase. Please refer to this.

1 Like

Thanks for the link!

Ok now that one problem is solved… I am having another. Every time I try to render a animation into armory it just loads a black screen. The troubleshooting section doesn’t seem to say anything about it so I ran it in the console. It says that the action “idle”(The animation) has fcurve channels with data paths that can’t be resolved. I have never done coding so I have no idea what it means. ( Here I found out what an fcurve is, but it makes less sense since I just made a few key frames and then tried to run armory.

There are two types of animation possible in Blender…One is the object animation where you animate mesh object (Position, rotation and scale). The other is when you animate an armature bones…so each bone will have its animation (like running, walking, etc.).

The error message you get seems to be a mix-up between these animations. That is you have applied a “bone animation” to a “mesh” object. Try to find and remove such animations.

If this still does not solve the issue, upload the blend file here will all external data packed in.

1 Like

Yes sir! I will give it a shot. Thanks!