Using Blender 2.79 for armory 06 and above

There are some people in discord that didn’t have support for Blender 2.8 meaning, they could not use armory 0.6 and newer. Not being able to use Armory which is lightweight because of blender is somewhat a letdown, and I know that Armory 0.6 and newer version was dropped for blender 2.79 because it was cumbersome for devs to handle 2 versions of blender. So, is it possible for community(@lubos excluded) to support blender 2.79, @lubos can work on 2.8 only while other support 2.79.
So, the only thing is to convert current 2.8 code to 2.79 on another repo and just copy-paste and convert newer changes from they main one, which doesn’t sound hard to support 2.79.

So this forum post is about discussion on whether to support 2.79 or not? what are it up and downs? is it even the worth?

Yes there is a need,if this. can be done, blender will be the overall best

Why can’t the users run Blender 2.80?

Is it because of bugs (Intel integrated opengl drivers have some issues), or is it because they are running on such old hardware they will never get OpenGL 3.3 support?

1 Like