Virtual gamepad with support multi-touch

People, who for money will help?)
Need a virtual joystick as in example virtual_gamepad with multi-touch support on Android

I’m interested in this too, will you give the code if will this happen?

Ideally, of course, so that others also support money:moneybag:
Since a very necessary thing.

The proceeds will go to the support fund

hello guys,

The objects are all multi-touch allowing you to build even very complex interfaces.
Test your project on multiple devices, especially if you plan to use more than two fingers at the same time.
For example, my LG G4, correctly manage 8 simultaneous fingers (beyond the octave the system no longer recognizes the release of the finger): I do not know if it is a limitation of the screen, system, browser, Construct, would be do some tests in this sense …

I wrote this software with last stable build of Construct 2, without using third-party plugins, so I think it can work with Construct 3 too (if you want, let me know if it works with Construct 3).
I could test this software only on Windows (tests on and Android. I have no idea if it works on other systems / platforms but I do not see why it should not work (if you want, you can give me feedback on …so I can update the documentation).

thanks and regards

Uh, they are asking about multi-touch in armory, not Construct 1/2/3

Here you go, VirtualGamepad.hx.

I used the virtual gamepad code and the multi touch example to write this version that hopefully works with multitouch. Unfortunately I don’t have the setup to test it, so please tell me if it does work. I also added some buttons to the gamepad to test it too.

On a different note, something I didn’t like is that everything is kinda hardcoded, so maybe an editor or something to allow making the virtual gamepad would be cool to add in the future, but I’m not sure how to tackle that one :sweat_smile:.

Oh, I didn’t think it was that hard to implement :thinking:
I will check as there will be free time.
Or someone else will beat me to it. :wink:
Importantly not forget here write then about results of test

nope, does not work :expressionless:
…even run Armory in fails

Ok, that’s a bummer :disappointed:. I tried to check it out myself but couldn’t get to compile an apk in Android Studio.

Can you give me some steps or a guide that worked for you to compile Armory projects to APK?

the furthest I got was to open the compiled project in Android Studio, and downloading some Android SDK but couldn’t even got it to compile.

If I get it to compile I could be able to debug it faster to get it to work.

In fact, I did everything according to the usual instructions.
The main system I have Kubuntu 19.04 OS

Using Blender 2.80.75 RC and Armory3D 2019.8
(2019.9 doesn’t seem worth using yet)
Downloaded Android Studio,
I installed openJDK, adb, and you may need other additional things. To do this, you should read about setting up Android Studio.

Then in Blender set the addon Armory, open the example files, say Billboard.
Tab [ Armory Render Path ] add [ Mobile ]

Tab [ Armory Exporter ] click plus and select Target [ Android © ]
Just in case, click save and on the [ Armory Player] tab click [ Clean ]

Tab [ Armory Exporter ] click [ Publish ]

At the top is the inscription Compiling… Or failed build in case of an error.
As a result, the project should be compiled for Android Studio.

Run Android Studio, select the folder where the Gradle files are located

Connect the phone, developer mode must be enabled.

the apk file will be located

My native language not English, because so sloppy explain)
Perhaps you will be a little clearer on my article, there are additional screenshots

on Windows

on Linux

Ok, thanks for the guide, I will try again and see if this time I can get it to compile so I can test the multitouch.

Update: I managed to get it to compile in a fresh project, so I tested the new virtual gamepad script and it seems to work in my side,

screenshot in my phone inside the app:

I didn’t find a way to get it to render default to landscape so the default cube looks all squashed :laughing:,

I didn’t test the buttons but the multitouch part seems to work with the pads, I may have to create an additional script to test the gamepad out.

Can you post the error log from the console when you try to build? and if possibly error log in Android Debugger?

Cool :+1: Maybe you’d better upload the entire folder so I can avoid possible setup errors on my part :sweat_smile:

Ok, I can upload the files, but basically what I did was:
I went to the scene tab and in scene traits I created a new Haxe trait and then created a new script and called it VirtualGamepad and then copied and pasted the code that I posted from before and that worked in a fresh project.

EDIT: added project file

Looks like my Android Studio was set up incorrectly…
Reinstalled it, now it seems normally compiled. Only compilation errors are confusing.
Joysticks work on the phone …seems :upside_down_face:

Now we need to check on a more complex example :thinking:

Cool seeing it work on your end too!

I still don’t like that everything is kinda hardcoded, so I was thinking about a way to make the virtual gamepad utility more flexible. So I was reading about macros in Haxe to generate custom code, and so the possibility arose to maybe allow for custom layouts for virtual gamepad easily with something like a json, or another format. If I get something working I’ll post it here.