Visual Studio 2017 compile hickup

Hi all, new here. Probably missing something basic.
Was able to find most of the includes I needed to compile except for:


I don’t have those headers anywhere. Windows SDK solved the rest that was missing. Stuck at this now.

Hey @Xico, welcome!

Could you provide more details on what project are you compiling? Everything should be set-up out of the box and there is a quick guide at

Hi Lubos. Thank you, great that I found your project, through tweeter actually.

I am actually doing the first tutorial with the Suzanne head rotating through script in blender.
Krom and HTML build are working peachy. Running on a 1070 without any problem.
I build it for c++ and then go over to Visual Studio 2017 and open the solution file. Had a load of includes that were missing and got that fixed by installing Windows SDK and pointing to them on the include path for the project.

But those four header files, I don’t have them on my computer. I can see the .hx files with the same name inside Kha but nowhere to be found are the .h files. I did follow the exact link to the quick guide you point to.
Searching through the web I can’t even find anyone else with the same problem either. Just oddly missing the files.
The compiler is now only complaining about that. Some way I can get them from some place ?

Even checking the repository for Kha or Armory 3D, the SystemImpl.h and ScreenRotation.h don’t even exist there.
So am really confused now as to where these two header files should be or where I can get them from.

Open visual studio installer. Click modify. Try to install “Game development with C++”. It did help me with some of the missing .h files. Dont forget to restart your pc.

Thanks for the tip @tumira but still the four header file aren’t on the system.
In your system where did these files ended up being ?

It is actually at the output folder of any project when I build it.

Hmm, ok so I’m missing a lot of files and some directory structure for some reason.

leading to the:

EDIT : No Sources directory subdirs from there, are the contents equal for all projects built ?

EDIT 2 : Tried to uncheck DCE. Double checked the root directory. Doing Build with runtime: C++. Armory v17.10 on Blender 2.79. Date 2017-09-09.

That is weird. Not sure what is happening.

Got past that part now with a clean fresh install.
Lots of ‘dsound.lib’ files in the system, tried to use all the directories they are in (one at a time) to include them but no luck.

Tried to install a recommended redistributable but no luck either, could dsound come from this ?

These are the redistributable installed packages on the system.

No clue how to Armory c++ from here on. :smiley:

Not sure what going on with your pc or setup. Usually I just setup armory to published to windows like this :-

and just follow the steps in this link

I dont need to include or do anything.

Found it.
In Linker->General->Additional Library Directories-> Added C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Lib
and all seems unicorny now.
Thanks for helping through the process.
Will leave this here in case anyone comes upon the same weirdness.