Visual Studio error when trying to build

While following the instructions as shown in the Manual Visual Studios says that when upening the .sln:

it says that teapot.vcxproj is not supported or that there are changes which have to be made, which can change the behavoiour of the project. When pressing ok, it is showing this:

and visual studio itself is pretty empty.
Is the manual outdated or am I doing something wrong? Here is the .blend: (Help)

This is Visual Studio 2017 correct ? Try to check if Visual C++ is installed. For me, it does not installed by default (I think I installed it from Unity installer so it only comes with C# and ?)

If you have windowsx.h missing or something , try to start Visual Studio installer and install something about creating games module for unity/cocos and etc. I forgot the name.

I tried it on my end, Build 14, latest version of VS - Works just fine:

Do you have the correct version of the Windows SDK or the necessary components installed? I get an error if I use anything below version 10.0.16299.0, but that’s also the only problem I’ve come across with native compiling.

Yep, somehow I managed to have Unity and Unreal Engine without having C++ stuff in Visual Studios installed. Doing that now. Thanks!
Edit: Yay it works now