Voxel scene not working for me

Several months ago, I fell in love with this video: http://www.youtube.com/watch?v=K47bNVIqv-4

It featured a nice voxel world and a build/erase blocks feature. I’ve tried to make it run a lot of times unsuccessfully. It always gets an “haxe error”.

See the console message here:

How can I make this to work? Just opening main file and pressing “play” seems not to be the way : /

This message was written alongside with the vid:

“Digging blocks in a little voxel-world experiment from the last weekend. To be released with Armory 0.4!”

I also found this in the 0.4 version release notes:

If it needs coding knowledge, what exactly does it need to be coded in order to make it work?

I’d like to know a bit more about it, is it still being worked on? Thanks in advance : )

I’ve been able to build this before with a slight modification to the code. I might get the chance to test it again and tell you what I changed. If you want you can try just commenting out the lines that the compiler is complaining about ( not usually a good idea, but I think it worked in this instance :wink: ).

The file that does the world generation doesn’t seem extremely complicated, but I think it does require a little bit of Armory knowledge of how to create the material and mesh for the environment.

Also there is the code to get the player to walk around the scene which looks a little bit involved.

I also did some experimenting with voxels in Armory because I didn’t understand that example:


So it was a code example and not a sample scene as I thought.
I fear I don’t have the coding knowledge to make the necessary ammendments.
I can tweak a line here and there but not much more. Thanks for the elaborated response and example : )

I tried your file in Armory, and this is what I get:

The playable file works nicely though.

1 Like

Hm, it should compile out of the box using 0.6beta, at least it seems to work here. Did you download the whole repository? It looks like the /Sources directory is missing or something. (Using Download ZIP button on GitHub is perfectly fine though.)

If you get past that, 0.6beta is missing some Direct3D11 fixes, you can switch to OpenGL in the add-on preferences and hopefully all should go smooth afterwards. :innocent:

1 Like