Krom not launching in linux


#1

Hello

I am loving armory 3d. It’s like the perfect engine for me.
My only question is that I can’t get krom to launch. I have tried it in both cycles and evie.
Runing it in my browser works fine and I can always use that, but it would probably be better if I used Krom.
Here is the output I get when runing from a terminal

[ace@shark Armory]$ ./blender
Read prefs: /home/ace/.config/blender/2.80/config/userpref.blend
found bundled python: /run/media/ace/Black/Armory/2.80/python
Warning: class UIToolsPreferences contains a properties which should be an annotation!
/run/media/ace/Black/Armory/2.80/scripts/addons/pie_menus_official/init.py:227
make annotation: UIToolsPreferences.use_pie_manipulator_of
make annotation: UIToolsPreferences.show_expanded_pie_manipulator_of
make annotation: UIToolsPreferences.use_pie_object_modes_of
make annotation: UIToolsPreferences.show_expanded_pie_object_modes_of
make annotation: UIToolsPreferences.use_pie_pivot_of
make annotation: UIToolsPreferences.show_expanded_pie_pivot_of
make annotation: UIToolsPreferences.use_pie_shade_of
make annotation: UIToolsPreferences.show_expanded_pie_shade_of
make annotation: UIToolsPreferences.use_pie_snap_of
make annotation: UIToolsPreferences.show_expanded_pie_snap_of
make annotation: UIToolsPreferences.use_pie_view_of
make annotation: UIToolsPreferences.show_expanded_pie_view_of
make annotation: UIToolsPreferences.use_pie_clip_marker_of
make annotation: UIToolsPreferences.show_expanded_pie_clip_marker_of
Armory: Proxy objects synchronized
Read blend: /run/media/ace/Black/Armory Files/Playground/Playground.blend

Armory v0.6 ($Id: ebccb44905d7131d996bc0d21e7836e6d91df402 $)
OS: linux, Target: krom, GAPI: opengl, Blender: 2.80 (sub 39)
Exporting Scene
Exporting mesh Cube
Scene exported in 0.008022546768188477
Exported modules: [‘audio’]
Shader flags: [’_Irr’, ‘_EnvCol’, ‘_Deferred’, ‘_ShadowMap’, ‘_CSM’, ‘_SinglePoint’, ‘_SSAO’]
Running: [’/run/media/ace/Black/Armory/armsdk//nodejs/node-linux64’, ‘/run/media/ace/Black/Armory/armsdk//Kha/make’, ‘krom’, ‘-g’, ‘opengl’, ‘–shaderversion’, ‘330’, ‘–parallelAssetConversion’, ‘4’, ‘–to’, ‘build_Playground/debug’]
Using project from /run/media/ace/Black/Armory Files/Playground
Using Kha from /run/media/ace/Black/Armory/armsdk/Kha
Creating Kha project.
Exporting asset 1 of 3 (Scene.arm).
Exporting asset 2 of 3 (World_irradiance.arm).
Exporting asset 3 of 3 (mesh_Cube.arm).
Exporting asset 1 of 2 (Material_data.arm).
Exporting asset 2 of 2 (shader_datas.arm).
Exporting asset 1 of 1 (brdf.png).
Compiling shader 1 of 13 (Material_mesh.frag.glsl).
Compiling shader 2 of 13 (Material_mesh.vert.glsl).
Compiling shader 3 of 13 (Material_shadowmap.frag.glsl).
Compiling shader 4 of 13 (Material_shadowmap.vert.glsl).
Compiling shader 5 of 13 (blur_edge_pass.frag.glsl).
Compiling shader 6 of 13 (compositor_pass.frag.glsl).
Compiling shader 7 of 13 (compositor_pass.vert.glsl).
Compiling shader 8 of 13 (deferred_light.frag.glsl).
Compiling shader 9 of 13 (pass.vert.glsl).
Compiling shader 10 of 13 (pass_viewray.vert.glsl).
Compiling shader 11 of 13 (ssao_pass.frag.glsl).
Compiling shader 12 of 13 (world_pass.frag.glsl).
Compiling shader 13 of 13 (world_pass.vert.glsl).
Compiling shader 1 of 8 (painter-colored.frag.glsl).
Compiling shader 2 of 8 (painter-colored.vert.glsl).
Compiling shader 3 of 8 (painter-image.frag.glsl).
Compiling shader 4 of 8 (painter-image.vert.glsl).
Compiling shader 5 of 8 (painter-text.frag.glsl).
Compiling shader 6 of 8 (painter-text.vert.glsl).
Compiling shader 7 of 8 (painter-video.frag.glsl).
Compiling shader 8 of 8 (painter-video.vert.glsl).
Done.
Finished in 3.5249907970428467

Also just so you know I am on manjaro linux and I’m runing the latest alpha of armory 3d (blender 2.8)
Thanks : )


#2

Try cleaning the project and running it again. I just ran into this, and then I fixed it somehow, but I can’t remember how anymore. :thinking:


#3

Can’t find any issue here, are you using Armory from itch.io or is it Armory from git
BTW it doesn’t matter if you are playing from cycles or from eevee, it got nothing to do with it.


#4

Im using armory drom itch. Also good to know that I can cycles and evie! Thanks : )


#5

Didn’t work : ( but thanks for your help anyways : )


#6

Can you test Armory 0.5 version and say if it is working or not?


#7

Still not working in 0.5


#8

As explained before, you choose Eevee or Cycles have no impact, because Armory 3D switches to it’s own render 3D engine automatically when you launch a game.
I think many users will continue do misunderstand that.


#9

i have the same problem.


#10

I wish Armory showed up as an option in the renderer dropdown alongside Cycles and Eevee, and then ran when people pushed F12. My guess is that this is how a lot of people expect to run Armory, and then they ask questions about which render engine to use because they don’t see Armory in the list…


An Armory Render Dropdown?
#11

Does browser runtime work for you? Any difference if you create a mobile path in the Armory Render Path panel and then launch in Krom?


#12

hello
Thank you for support.
I have no problem with the browser.(chromium)


#13

run with terminal
output:
Read prefs: /home/iman/.config/blender/2.80/config/userpref.blend
Received X11 Error:
error code: 182
request code: 156
minor code: 34
error text: GLXBadFBConfig
Received X11 Error:
error code: 182
request code: 156
minor code: 34
error text: GLXBadFBConfig
Received X11 Error:
error code: 182
request code: 156
minor code: 34
error text: GLXBadFBConfig
Received X11 Error:
error code: 182
request code: 156
minor code: 34
error text: GLXBadFBConfig
Received X11 Error:
error code: 182
request code: 156
minor code: 34
error text: GLXBadFBConfig
Received X11 Error:
error code: 182
request code: 156
minor code: 34
error text: GLXBadFBConfig
Warning: Could not find a matching GPU name. Things may not behave as expected.
Detected OpenGL configuration:
Vendor: X.Org
Renderer: AMD CEDAR (DRM 2.50.0 / 4.15.0-45-generic, LLVM 7.0.1)
Received X11 Error:
error code: 8
request code: 156
minor code: 34
error text: BadMatch (invalid parameter attributes)
Received X11 Error:
error code: 8
request code: 156
minor code: 34
error text: BadMatch (invalid parameter attributes)
Received X11 Error:
error code: 8
request code: 156
minor code: 34
error text: BadMatch (invalid parameter attributes)
Received X11 Error:
error code: 8
request code: 156
minor code: 34
error text: BadMatch (invalid parameter attributes)
Received X11 Error:
error code: 8
request code: 156
minor code: 34
error text: BadMatch (invalid parameter attributes)
Received X11 Error:
error code: 8
request code: 156
minor code: 34
error text: BadMatch (invalid parameter attributes)
found bundled python: /home/iman/.Apps/Armory3d/2.80/python
Armory: Proxy objects synchronized
Read blend: /home/iman/Documents/Projects/Test/Armory3d/4/untitled.blend
ﺕﺎﻋﻼﻃﺍ: Saved “untitled.blend”

Armory v0.6 ($Id: 988482e02afefe458b00e4dea75db2d01b76e49d $)
OS: linux, Target: krom, GAPI: opengl, Blender: 2.80 (sub 44)
Exporting Scene
Exporting mesh Cube
Scene exported in 0.004419088363647461
Exported modules: [‘audio’]
Shader flags: [’_Irr’, ‘_EnvCol’, ‘_LDR’, ‘_ShadowMap’, ‘_SinglePoint’]
Running: [’/home/iman/.Apps/Armory3d/armsdk//nodejs/node-linux64’, ‘/home/iman/.Apps/Armory3d/armsdk//Kha/make’, ‘krom’, ‘-g’, ‘opengl’, ‘–shaderversion’, ‘330’, ‘–parallelAssetConversion’, ‘4’, ‘–to’, ‘build_untitled/debug’, ‘–nohaxe’, ‘–noproject’]
Using project from /home/iman/Documents/Projects/Test/Armory3d/4
Using Kha from /home/iman/.Apps/Armory3d/armsdk/Kha
Creating Kha project.
Exporting asset 1 of 3 (Scene.arm).
Exporting asset 2 of 3 (World_irradiance.arm).
Exporting asset 3 of 3 (mesh_Cube.arm).
Exporting asset 1 of 2 (Material_data.arm).
Exporting asset 2 of 2 (shader_datas.arm).
Compiling shader 1 of 4 (Material_mesh.frag.glsl).
Compiling shader 2 of 4 (Material_mesh.vert.glsl).
Compiling shader 3 of 4 (Material_shadowmap.frag.glsl).
Compiling shader 4 of 4 (Material_shadowmap.vert.glsl).
Compiling shader 1 of 8 (painter-colored.frag.glsl).
Compiling shader 2 of 8 (painter-colored.vert.glsl).
Compiling shader 3 of 8 (painter-image.frag.glsl).
Compiling shader 4 of 8 (painter-image.vert.glsl).
Compiling shader 5 of 8 (painter-text.frag.glsl).
Compiling shader 6 of 8 (painter-text.vert.glsl).
Compiling shader 7 of 8 (painter-video.frag.glsl).
Compiling shader 8 of 8 (painter-video.vert.glsl).
Done.
Finished in 4.61983060836792


#14

krom worked in windows 10.


#15

It’s working for me in Linux (both 0.6 from itch.io and git). Kubuntu Linux 18.10 - 64 bit.