Armory error occured during compilation

Could you please try enabling Verbose Output and reshare the console logs? If it’s easier, you can just copy-paste them here instead of taking screenshot(s).

1 Like

is it possible to copy from the console window? could you tell me how? yes it would much easier

Just hover over the console window and select the text from the console and copy the text using Ctrl+C to copy the selected content, and then move over here (the forum) and do Ctrl+V to paste the copied content here.

i tried it but it doesnt let me copy or select, only type. i cant scale the window also

Maybe try exiting Armory before you try to select/copy from the terminal? Are you sure the console is even active? (Just because you see it doesn’t mean the console window itself is active.) Make you sure click onto the console window itself to ensure it’s active.

i opened in windows > toggle system console. when i exit blender the windows close as well

I think you misunderstood. I didn’t say exit Blender: I said exit Armory.

I didnt understand. since armory is an addon of blender, how could i exit without closing blender?

This is what the Armory Play button looks like when Armory is inactive.

And this is what the button looks like when Armory is active. When Armory is active, click the button to stop Armory.

In any case, it appears you’re confused on what Armory is. Yes, Armory is a Blender add-on, but the add-on is just a plugin and not the engine itself: which Armory is. The add-on exports to Armory and runs the Armory engine externally. It runs in a separate window.

oh when i get the error it imediately stop. however i cant copy what says in system console, i looked online and found another thread the guy was having problems too and he took screenshots of it. i still dont know how to copy it

Could you please check to see if there is an existing file such as this in your ARMSDK Krom folder? [SOLVED] Armory closes when minimized with code 3221225477 - #4 by rpaladin And if it does exist, share it here.

hello theres no such file there inside krom folder

by “stop” i mean that after i press play it doesnt keep active, it stop and shows the little red text under it says that 1 error occurerd. it doesnt crash the blender app

Never said it should. Again, you seem to be confused between Blender and Armory… In any case, I have no more suggestions on how to help debug the error you’re getting.

If your project is small enough, could you please share the blend?

yes i can share it but i didnt make anything inside of it or imported soemthing to it since the game engine isnt working. i just downloaded it to see what is armory, get know it before importing my models

untitled.blend (941.1 KB)

I tried your blend and it works fine for me in Armory (I’m on Windows 11). I think your Windows 7 is being buggy with Armory. But then again, you mentioned that your Windows 7 compatible version of Blender is also missing the Armory UI properties in Blender and appear to be broken. I think this may be more of a Blender issue, not an Armory issue (but it could be both).

I’m curious, did you download your Windows 7 compatible version of Blender version from here?: GitHub - nalexandru/BlenderCompat: Windows 7 support for Blender 3.x

hey i managed to copy it ! i didnt jknow i had to click twice inside the box

addon_utils.disable: armory not disabled
Modules Installed (armory) from ‘C:\Users\Mario\Downloads\ArmorySDK2309\arm
sdk\’ into ‘C:\Users\Mario\AppData\Roaming\Blender Foundation\Bl
Running Armory SDK from C:\Users\Mario\Downloads\ArmorySDK2309\armsdk/
Info: Total files 2 | Changed 2 | Failed 0
Using CPU for environment render (might be slow). Enable CUDA if possible.
Saved: ‘C:\Users\Mario\Downloads\New Folder\build_untitled\compiled\Assets\envma
Time: 00:00.24 (Saving: 00:00.02)

CMFT info: Converting latlong image to cubemap.
CMFT info: Saving spherical harmonics coefficients to C:\Users\Mario\Downloads\N
ew Folder\build_untitled/compiled/Assets/envmaps/env_World_irradiance.c
CMFT info: Done.
exe’, ‘–input’, ‘C:\Users\Mario\Downloads\New Folder\build_untitled/compil
ed/Assets/envmaps/env_World_radiance.jpg’, ‘–filter’, ‘radiance’, ‘–dstFaceSiz
e’, ‘128.0’, ‘–srcFaceSize’, ‘128.0’, ‘–excludeBase’, ‘false’, ‘–glossScale’,
‘8’, ‘–glossBias’, ‘3’, ‘–lightingModel’, ‘blinnbrdf’, ‘–edgeFixup’, ‘none’,
‘–numCpuProcessingThreads’, ‘4’, ‘–useOpenCL’, ‘true’, ‘–clVendor’, ‘anyGpuV
endor’, ‘–deviceType’, ‘gpu’, ‘–deviceIndex’, ‘0’, ‘–generateMipChain’, 'true
', ‘–inputGammaNumerator’, ‘1.0’, ‘–inputGammaDenominator’, ‘1.0’, ‘–outputGa
mmaNumerator’, ‘1.0’, ‘–outputGammaDenominator’, ‘1.0’, ‘–outputNum’, ‘1’, ‘–
output0’, ‘C:\Users\Mario\Downloads\New Folder\build_untitled/compiled/Asse
ts/envmaps/env_World_radiance’, ‘–output0params’, ‘hdr,rgbe,latlong’, '–silent
WARNING: Generating the radiance map with CMFT took an unusual amount of time (2
2.79 s). If the issue persists, try disabling “CMFT: Use OpenCL” in the Armory a
dd-on preferences. For more information see
C:\Users\Mario\Downloads\ArmorySDK2309\armsdk/nodejs/node.exe C:\Users\Mario\Dow
nloads\ArmorySDK2309\armsdk/Kha/make krom -g direct3d11 --shaderversion 330 --pa
rallelAssetConversion 4 --to build_untitled/debug --quiet
Compiling shader 2 of 20 (compositor_pass.frag.glsl) failed:
Shader compiler error.
(node:3168) UnhandledPromiseRejectionWarning: Shader compiler error.
(node:3168) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This
error originated either by throwing inside of an async function without a catch
block, or by rejecting a promise which was not handled with .catch(). (rejection
id: 2)
(node:3168) [DEP0018] DeprecationWarning: Unhandled promise rejections are depre
cated. In the future, promise rejections that are not handled will terminate the
Node.js process with a non-zero exit code.
Compiling shader 1 of 20 (blur_edge_pass.frag.glsl) failed:
Shader compiler error.
Compiling shader 3 of 20 (compositor_pass.vert.glsl) failed:
Shader compiler error.
Compiling shader 4 of 20 (deferred_light.frag.glsl) failed:
Shader compiler error.
Finished in 26.809s
WARNING: 1 warning occurred during compilation
ERROR: Build failed, check console

yes i did download it from there

I unfortunately can’t tell what are causing those last, crash related errors, but regarding this warning:

You can resolve by disabling the highlighted option in your Blender Preferences for your Armory add-on:

After disabling the option, save your Preferences and close/reopen Blender, as usual. You might not need to do this last step, but it can’t hurt to go through those steps.

1 Like

Thank you so much for yyour support and attempt to help. i will try again wehn i get win10.