Issue with metallic, glosy textures


i have searched every where for an answer but couldnt find one, the issue being objects with metallic textures are very dark and the true colour of the metal texture does not show correctly.

i have set up other objects with none metallic textures and they are great it is just metallic i am having issues with does anyone know why?

i have SSR turned on. is there some other magically setting i need to switch on?

EDIT: i also downloaded the teapot example and the balls and teapots with glossy materials looked black.

The background world is usually reflected as being black, unless you’ve an HDR map set as the environment map under the world tab - you can hold some nice free HDR’s here:

that’s a bug. glossy material look too rough at lower values


I am new at Armory3d but I am facing the same problem as above.
I got metal textures on some of my objects but they all look dark and nothing like metal. I tried to set an environment texture, but then I ran into two other problem. First the image does not show up in the background. Second when “radiance” is turned on in the world tab armory wouldn´t start at all. And throws an FileNotFoundError message. Seems it is looking for the HDR file with an additional “_0” in it´s name. I found this issue already here in the community and it seemed solved year ago but I still got it.
I am using the ArmorySDK2020-11.

Can anybody help?

It will depend on the result you want, but you have two alternatives:

  1. If you don’t want to use a HDR or Sky Texture, you may reduce the material metalness to near 0.9.

  2. You can enable Sky Texture or use some HDR (i don’t know which exactly HDR yet).

Use this example to see what i said: untitled.blend (787.8 KB)

  1. The world is white, but with 1.0 metalness, in Armory the world will be considered black. Reduce the metalness to 0.9 and the darkness will disappear in Armory.

  2. Keep the metalness in 1.0 but enable Sky Texture.

thanks for the quick response. Okay by dropping down the metalness everything becomes brighter. It´s okay to go ahead now.
But I am still wondering why the image is not showing up in the background, I hoped it would be reflected on the surfaces.
I thought this is related the problem mentioned in How do you use enviorement maps?
Because the same error message pops up as long aradiance is enabled. And maybe the HDR is not compiled correctly.

You need to clean the cache to ensure that everything will be updated, but the materials in Armory will be rendered different from eevee (some properties in Armory PBR don’t affect eevee). I don’t see any problem with the reflections, but if the problem is related to your HDR file, you can test using another HDR from HDRI Haven to make sure (this ones i know that works fine).

This is how the material is rendered in Eevee:

Armory 1.0 occlusion:

After changing occlusion to 4.0, the reflections in Armory are more clear (values above 4.0 and below 0 will not work):

Another comparison for Occlusion 1.0 and 4.0 respectively in Armory:

Here is the settings in material properties:

Captura de tela de 2020-11-06 13-58-22

1 Like