[SOLVED] Help! Black Screen on build or play - No Errors

Hi im running linux mint on my laptop. i downloaded Armory_04b_linux64_b27.7z file.
When i hit build or play,a new window pops up,but its completely black. No errors in blender console.
Im getting a black screen in chrome too when i build it for browser.
i tried running a few webgl tests to ensure its not my graphics drivers, but webgl tests run fine.
Please help.
I also tried forward rendering,deffered rendering, legacy shaders etc. Nothing works, only black screen and no errors.

sorry now im getting these errors
GLSL compiler error: 0:1(10): error: GLSL 3.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

GLSL linker error: error: linking with uncompiled shadererror: linking with uncompiled shader
Uniform dirInv not found.

glxinfo? driver versions and what kind of drivers?

server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
Max core profile version: 0.0
Max compat profile version: 2.1
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 2.0
OpenGL version string: 2.1 Mesa 17.2.8
OpenGL shading language version string: 1.20
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 17.2.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16

its an old laptop though,will armory work on it?

I guess minimum profile is OpenGL ES 2.0 but it looks like your OpenGL version is too old.
I’d try minimum/mobile preset. Also in plugin options you can try enable “old” shaders.
I will have the same problem on not so old laptop too soon enough as it supports only OpenGL 3.0 and min version seems 3.3…

just for records, what video card that is?

im not sure its an acer laptop 5740g, how do i check which video card on linux?

Laptops can have various configurations. You can check either using lspci command as root and look for something like VGA and see actual video card name nearby, and other way is to run some high level tool.
I really don’t remember which tool that is as I don’t use these…

i tried mobile preset, same thing…just a black screen, same errors

Also you can check your /var/log/Xorg.log.0 (or some similar name) for what it can tell about your video card near DRI: lines.

I think that it is strange your video supports only GLSL1. Have you tried git mesa for your card?
have you checked compatibility and features? First you need to really find out which video card is installed to your laptop.

What I have is this:

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 660/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 390.48
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

Notice video card name in renderer string.

lspci -vnn | grep VGA -A 12
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 12) (prog-if 00 [VGA controller])
Subsystem: Acer Incorporated [ALI] Core Processor Integrated Graphics Controller [1025:033e]
Flags: bus master, fast devsel, latency 0, IRQ 25
Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 1800 [size=8]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Kernel driver in use: i915
Kernel modules: i915

00:16.0 Communication controller [0780]: Intel Corporation 5 Series/3400 Series Chipset HECI Controller [8086:3b64] (rev 06)
Subsystem: Acer Incorporated [ALI] 5 Series/3400 Series Chipset HECI Controller [1025:033e]

as far as i know, my laptop is a 5740G which has an ati card apart from intel integrated graphics, but i think linux is not using the ati card, it was switchable graphics or something

Ah embedded in CPU. Try Legacy Shaders option in plugin options. After setting that clean your project.

Acer Aspire 5740 Series. Processor: Intel Core i3 330M, Intel Core i5 430M.
Graphics Adapter: ATI Mobility Radeon HD 5650, Intel Graphics Media Accelerator (GMA) HD Graphics.
Display: 15.6 inch.

i googled my model and found this,apparently linux uses only the integrated graphics and not the ati radeon

I don’t know how to make ATI switchable video work, but that should be definitely possible, google for it.

i think it’ll be a tedious task to get it to work on linux,but i’ll try,but any other way to get armory to work with the integrated graphics ?

ok so setting legacy shaders on and mobile preset works