Transparency Tests

So I was playing with transparency and got it working! It works with PBR if you set the strenght under 1, like .999, but we kind of see through. So it works best using Cycles nodes with transparency.

Both however do not cast transparent shadows on the ground.

Here is 2 screenshots at the test.

1 Like

I have the same transparency issue here with the windows of a house, the 0.999 value makes the house transparent overhaul, but here the transparent shadows do work. I think there is an option that activates them.

Did some improvements here, next build out on Friday. 0.999 value to activate it should be no longer needed then, plus improved shadow casting :slight_smile:

You ROCK lubos :wink: So far, even for an early build, its pretty stable for the most part! I cannot wait to play with more logic nodes :slight_smile:

Small test of transparent textures. New build 4.
Only shadows are visible. :slight_smile:
What do i wrong? (should be mapped cube)

Adding same texture (color or alpha) to opacity channel let everything disappear.

Testing transparency with some trees on Build 7 of Armory3D on a Mac Book Pro gave me odd results:
Screen Shot 2017-02-20 at 3.36.52 PM

Screen Shot 2017-02-20 at 3.37.08 PM

Screen Shot 2017-02-20 at 3.37.32 PM

The shadows look great, but the foliage has this odd addition blend mode effect, although on the Armory PBR Group node I’m not sure if I’m setting it up right. On the other hand the standard Cycles Group Node produces a similar effect, which normally in most tutorials I’ve seen it should look more like if alpha clipping were enabled. If I do have everything set up in nodes properly is there another setting that determines blending modes or something? I’m a bit puzzled.

Do you have the .blend file so i can test it ?

I tried another test including a separate black and white transparency map using the ArmoryPBR group, since it gave the best results, but the same or similar opacity issues persist. This 2nd test file is a bit cleaner with only 3 textured cubes. There still appears to be some sort of alpha sorting and emission problems as it would seem.

Some more results:
alpha sorting problem (skytexture and 1 lamp present)

emission problem when only skytexture is present (no lamps):

diffuse map

alpha map

2ndTransparencyTest.blend (906.1 KB)

(Edit) Here is the current node layout,

Hello i was able to reproduce the problem with my system (OS X® 10.11.6 ) even with deferred_path_high as suggested here:

I also tried to add alpha channel to the diffuse texture but the problem is the same:

At the end i suggest to post this issue on Armory GitHub.

Thanks for testing! Must be (another) transparency bug - will investigate and report back. Maybe going with different technique for rendering transparent surfaces would be the best solution.

Selecting deferred-high path is not needed anymore, it is enough to set Camera - Armory Render Path - Translucency to Auto on On. By default it is set to Auto - if translucent material is detected then render path builder will set it up automatically. On the other hand if no translucency is used then some resources/perf is saved. :slight_smile:

1 Like

As reference in my test i tried with Translucency “On” but the issue persist.

This topic seemed like a bit of a loose end at this point… I figure I’d mention that in build 12, the Discard option in the Armory Material Properties has solved all the issues so far seen in this thread with sorting and opacity! Woo!

(pardon the year old bump)


Oh wow this is cool! Happy the Discard option works.

1 Like

Hello, I’m digging up this topic :smiley:

I also have a problem with transparency.
I did enable “translucence” in Armory Render Path -> Renderer, my material is an Armory PBR, but I have no transparency until I check the “Discard” box.
With Discard checked, it is all or nothing: if the opacity of my materials is lower than the value of “Mesh Opacity”, my object is totally invisible.

Did I forget something?
Is it not possible to have anything other than a totally transparent or totally opaque object?

Thank you!

Translated with

Hi, i have a problem with transparency
in the img below the rotating letters should normally go behind her head
but they appear always on top.
I am using Armory PBR with Renderer/Translucency -> ON


btw, i tried setting the plane (with the girl) to “Armory Props -> Discard”
but it produces a weird fringe.
Is there a way to make the letter go around here without using Discard?

any help will be appreciated

here is the file as well
marquee-1.blend (499.3 KB)

Thank you.

I am having issues with particles with the tile sheet and transparency too. I can get the particles working fine but getting them to look right is driving me nuts. If anyone has gotten in to work a write up world be awesome. I have studied the smoke example and can not seem to replicate it.


I’m stuying the smoke example too and try to get my sprite sheet work … when i have a result, i will post but not sure to get this work :slight_smile:

1 Like

I will keep at it too. I might have to skip this step for a while to keep my video series going.

@nassosyian I would just use the discard function and also use a different file format with an extra alpha channel like tga.

this is how I would setup my texture

for the text image I just put the actual text into the alpha channel of the tga and the rgb channels are completely white.

I played with smoke example, try to tweak it, but it seems we can not achieve a acceptable effect in blender … may be there is a beginning of answer here : . Sprite sheet need to be in .png to have the transparency in armory viewport but blender not seems to manage emissive with transparency correctly. I tried many attempts in photoshop to store emissive of fire simulation in alpha channel to create a torch sprite sheet without sucess. However i can tell that sprite sheet seems working. I will try to share another smoke scene that reproduce this example.