Web presentation at home with a little interactive (html5)

Small scene (some kind of sketchfub analogy)
https://projectbp.ru/Download/3d/A_253/index.html

Thank you very much for the help: e1e5en and timodriaan!
I couldn’t have done it without them.

The work will continue…

6 Likes

Excellent! I am curious about the user interface. Did you use Koui?

1 Like

Yes! Exactly.
I really liked the developer’s approach to this component. Today I have such an interface
23213

Thanks for your feedback!

3 Likes

Thanks for reply! You convinced me to start using Koui. Greetings from France!

6 Likes

Something like the final scene from the link:
https://projectbp.ru/Download/3d/A_38/index.html

Download file from the link:

For correct work, place the files RotateObjectArcBallNode.hx and RotateCameraWalkNode.hx
in /ArmorySDK/armory/Sources/armory/logicnode/

files LN_rotate_object_arcball.py and LN_rotate_object_walk.py
in /ArmorySDK/armory/blender/arm/logicnode/transform/

Thanks E1e5en for the help with custom nodes.

Let us know if there are problems with the materials. Perhaps I forgot something.

If you have thoughts on how to improve the scene, I will be glad to help)

4 Likes

Hello kaiwas,
Blender is crashing when opening the file.
I have Blender 2.83 and Armory 2020-12, could you please tell me which version of Blender / Armory3D you are using?

Hello!
I have overwritten the archive file. Re-download

The problem arises when the KOUI logical chain is active (Canvas_NODE). Does not depend on the blender version. I checked in 2.83

If you temporarily disable the kowi (for example, rename the “libraries” folder). Copy the chain into a new node tree with a different name (for example,Canvas_NODE_NEW) . Save. Exit. Activate KOUI and start again - it should work.

Thank you for your reply!
The file now opens but I got errors while compiling.
I’ll check it out at the end of the day, I have to go to work!

That’s indeed because of the nodes, Blender has issues registering nodes after a file is loaded (which we need to do for node packages): https://github.com/armory3d/armory/issues/1890. I hope that it will be fixed soon or that we find some kind of workaround.

In Linux can open and use portable files. Sometimes it starts on the first try, sometimes on the third or fifth. But sooner or later it works

I can open the file, le Koui nodes seems to be loaded but Blender crashes when I want to add one of them or when I try to edit the canvas_node.
I tried to temporaly disable Koui with no success.
I’m a beginner and and I’m not sure to find a solution to get it work.
Thanks for your help!

you just need to be patient and maybe the problem will be solved at the software level)
or just build your new tree of nodes)))
I’m a newbie too;)

I can show the node tree in the video. tomorrow.
so that you can reproduce

1 Like

Yeah, I really appreciate your help!
It can really help me to understand Koui.

Just a small remark: the Koui nodes are in a very early stage and there might be some breaking changes in the future. Also they’re far from complete yet. If you have suggestions or missing a functionality let me know :slight_smile: The goal is to have (almost) the entire Haxe API of Koui available as nodes, but developing them is a bit tedious right now because of said Blender bugs/crashes.

2 Likes

Canvas_NODE.jpg )))

from Russia with love ! :laughing:

2 Likes

Already now, the KOUI has a functional that allows you to implement a not complicated, but nice GUI. I like it!

3 Likes

Thanks a lot! :star_struck:

Hi, timododriann, I’m just a user, I have no skills at all for programming (that’s what I love Armory3d) and I have a lot of respect for your job. Koui seems amazing to me, I really want to learn it and use it in a future project. I’m pretty sure that I will love Koui as much as Armory3D!

3 Likes